Build: #37 failed Changes by Martin Lippert

Build result summary

Details

Completed
Duration
98 minutes
Labels
None
Agent
bamboo-21.af.pivotal.io
Revision
2920654de63c8725efeed2334309806a1489180f 2920654de63c8725efeed2334309806a1489180f
Total tests
1162

Tests

Responsible

Code commits

Author Commit Message Commit date
Martin Lippert Martin Lippert 2920654de63c8725efeed2334309806a1489180f 2920654de63c8725efeed2334309806a1489180f added missing package-import for javax.inject

Tests

New test failures 5
Status Test View job Duration
Collapse Failed BootLaunchShortcutTest testConfigurationDeletedWhenProjectDeleted History
Default Job 3 secs
java.lang.AssertionError: Expecting no problems but found: Marker {
   rsrc = /empty-boot-project/pom.xml
   severity = 2
   causeLineNumber = 109
   charEnd = 524
   causeColumnEnd = 12
   message = Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.6:resources failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-resources-plugin:2.6:resources: java.lang.LinkageError: loader constraint violation: when resolving method "org.codehaus.plexus.interpolation.PrefixedValueSourceWrapper.<init>(Lorg/codehaus/plexus/interpolation/ValueSource;Ljava/util/List;Z)V" the class loader (instance of org/codehaus/plexus/classworlds/realm/ClassRealm) of the current class, org/codehaus/plexus/interpolation/PrefixedObjectValueSource, and the class loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) for the method's defining class, org/codehaus/plexus/interpolation/PrefixedValueSourceWrapper, have different Class objects for the type org/codehaus/plexus/interpolation/ValueSource used in the signature
-----------------------------------------------------
(486 more lines...)
Collapse Failed EditStartersModelTest addBomWithSubsetOfRepos History
Default Job 2 mins
org.eclipse.core.runtime.CoreException: AssertionError: The wanted bootVersion '2.1.6.RELEASE'is not found in the wizard
	at org.springsource.ide.eclipse.commons.livexp.util.ExceptionUtil.coreException(ExceptionUtil.java:46)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness.assertOk(BootProjectTestHarness.java:371)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.test(BootProjectTestHarness.java:288)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.doTest(ACondition.java:143)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.waitFor(ACondition.java:103)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.<init>(ACondition.java:87)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.<init>(BootProjectTestHarness.java:285)
(10 more lines...)
Collapse Failed EditStartersModelTest addMultipleStartersWithSameBom History
Default Job 2 mins
org.eclipse.core.runtime.CoreException: AssertionError: The wanted bootVersion '2.1.6.RELEASE'is not found in the wizard
	at org.springsource.ide.eclipse.commons.livexp.util.ExceptionUtil.coreException(ExceptionUtil.java:46)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness.assertOk(BootProjectTestHarness.java:371)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.test(BootProjectTestHarness.java:288)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.doTest(ACondition.java:143)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.waitFor(ACondition.java:103)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.<init>(ACondition.java:87)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.<init>(BootProjectTestHarness.java:285)
(10 more lines...)
Collapse Failed EditStartersModelTest addDependencyWithRepo History
Default Job 2 mins
org.eclipse.core.runtime.CoreException: AssertionError: The wanted bootVersion '2.1.6.RELEASE'is not found in the wizard
	at org.springsource.ide.eclipse.commons.livexp.util.ExceptionUtil.coreException(ExceptionUtil.java:46)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness.assertOk(BootProjectTestHarness.java:371)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.test(BootProjectTestHarness.java:288)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.doTest(ACondition.java:143)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.waitFor(ACondition.java:103)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.<init>(ACondition.java:87)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.<init>(BootProjectTestHarness.java:285)
(10 more lines...)
Collapse Failed EditStartersModelTest addMultipleStartersWithDifferentBom History
Default Job 2 mins
org.eclipse.core.runtime.CoreException: AssertionError: The wanted bootVersion '2.1.6.RELEASE'is not found in the wizard
	at org.springsource.ide.eclipse.commons.livexp.util.ExceptionUtil.coreException(ExceptionUtil.java:46)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness.assertOk(BootProjectTestHarness.java:371)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.test(BootProjectTestHarness.java:288)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.doTest(ACondition.java:143)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.waitFor(ACondition.java:103)
	at org.springsource.ide.eclipse.commons.frameworks.test.util.ACondition.<init>(ACondition.java:87)
	at org.springframework.ide.eclipse.boot.test.BootProjectTestHarness$7.<init>(BootProjectTestHarness.java:285)
(10 more lines...)