Build #2,957

Next Gen Reactor Addons

Build: #2957 failed Changes by Simon Basle

Code commits

reactor-addons

  • Simon Basle

    Simon Basle 0a9023653af472dde9d27bd02889d2dc784e965d

    Improve cache support over #131 (#133)
    Improve cache support over #131
     - use NonNullApi annotation at package level rather than NonNull on
     methods
     - follow generic type naming convention of using ALL_CAPS
     - add lookupFlux methods + associated reader/writer/builder interfaces
     - make sure the returned Mono/Flux are lazy and tests
     - split CacheHelper into MonoCaching and FluxCaching
     - added a way to provide the source lazily via Supplier
     - improved Doc
     - less generics in the Flux-from-Map version, but need Class parameter
     - rename to Cache[Flux/Mono]#lookup, remove FunctionalIF annot on builders

    • reactor-extra/src/test/java/reactor/cache/CacheFluxTest.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/main/java/reactor/cache/CacheFlux.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/main/java/reactor/cache/CacheHelper.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/main/java/reactor/cache/CacheMono.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/main/java/reactor/cache/package-info.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/test/java/reactor/cache/CacheHelperTest.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)
    • reactor-extra/src/test/java/reactor/cache/CacheMonoTest.java (version 0a9023653af472dde9d27bd02889d2dc784e965d)